X-Sim einstellen für 2DOF mit Arduino und Sabertoo  Topic is solved solved with post #22328

Deutsche Sprache - beachtet den Google Übersetzer oben rechts

X-Sim einstellen für 2DOF mit Arduino und Sabertoo

Postby menix » Tue 27. Feb 2018, 08:18

Nach 5 Jahhren Abstinenz wollte ich meinen Sim mal weiterbauen.
Hatte vorher vellemann Board und bin jetzt auf Arduino umgestiegen.Muss daher alles neu machen und weiss eigentlich gar nix mehr von früher
Vorhanden:
Arduino Uno, Sabertooth 2x24V, 2 Rollstuhlmotoren, 2x Poti und Netzteil.
Xpid SOftware für Sabertooth installiert .
Jetzt bräuchte mal ne Schhritt für Schritt Anleitung am Besten mit Bildern wie es weitergeht.
Wo fange ich an nachdem alles verkabelt ist.
Der Einfachheit halber will ich das ganze erst mal mit einer Achse machen.
Das Tutorial is so verwirrend und ich blick da gar nicht durch.
WIe kann ich x-sim einstellen erstmal ohne ein Spiel damit ich die richtigen Bewegungen usw. habe
Und wie kann ich das dann testen? WIe geht das mit den Slidern?
Fragen über Fragen.
Wichtig wäre mir erstmal wo stelle ich die Begrenzung über die Potis ein
und wo stelle ich die Geschwindigkeit der Motoren ein.
Da ich meine Motoren nicht mit der Hand drehen kann wäre es gut sie langsam über einen Slider zu den Endpositionen zu fahren.
Ich glaube meine Poti gehen ziemlich genau mit der Übersetzung aber ich will mich da vorsichtig rantasten.
Wenn ich z.B bei Set output was eingebe rasen die Motoren volle Pulle und das will ich vermeiden.

Bin ein Stück weiter.
Bei Interface settings fahren meine Motoren beo 0% und bei 100% in die maximale Position, bei 50% in Mittelstellung.
Allerdings geht mein Poti bei 0% nur auf 16 und bei 100% nur auf 1011 Value Wert
es fehlen also auf beiden Seiten etwa 10 bis 15 Werte also nicht genau 100% Weg aber das sind nur millimeter denke ich.
menix
 
Posts: 36
Joined: Tue 20. Mar 2012, 19:44
Has thanked: 1 time
Been thanked: 0 time

Re: X-Sim einstellen für 2DOF mit Arduino und Sabertoo

Postby DannyT » Wed 28. Feb 2018, 10:01

Hallo,

Wie hast du die Endpositionen der Potis eingegeben?
Bin übrigens in der gleichen Situation wie du und mit der neuen Software überfordert...
Welche Simulation betreibst du?

Gruß
Danny
DannyT
 
Posts: 11
Joined: Tue 12. Mar 2013, 17:56
Has thanked: 0 time
Been thanked: 0 time

Re: X-Sim einstellen für 2DOF mit Arduino und Sabertoo

Postby menix » Wed 28. Feb 2018, 10:10

Hier ist mein Sim
viewtopic.php?t=764

Habe den Poti mit Zahnrädern mit dem Motor verbunden , hab das Verhältnis Drehung/Poti als Getriebe übersetzt.
Und bei Xpid die Werte angeschaut bei jeweils maximum links/rechts
Daher weiss ich das die Werte ok sind.
Ich mach mal ein Bild heute wenn ich dazukomme.
Mir gehts eigentlich darum dass ich erstmal eine komplette Grundeinstellung meines Simulatiors habe die Profile von den Spielen kann man dann ja laden.

Diese Grundeinstellung will ich dann speichern dass ich die immer gleich habe, Feintuning kommt danach, nur weiss ich jetzt nicht wie ich weitermachen muss.
DIe Dokumentation ist hier nicht sehr hilfreich darum habe ich den Thread eröffnet.
menix
 
Posts: 36
Joined: Tue 20. Mar 2012, 19:44
Has thanked: 1 time
Been thanked: 0 time

Re: X-Sim einstellen für 2DOF mit Arduino und Sabertoo  Topic is solved

Postby DannyT » Wed 28. Feb 2018, 10:43

Ah, ok...
Ja, das Forum hier ist nicht hilfreich. Viele Fragen bleiben unbeantwortet. Die Trainingseinheiten und Dokumente sind völlig veraltet. Ist wirklich schade....
Bin heute Abend wieder basteln..Ich kann den Extractor nicht einloggen. So komme ich nicht weiter..Schade...
Ansonsten wüsste ich, was mit dem Setup zu tun ist.
DannyT
 
Posts: 11
Joined: Tue 12. Mar 2013, 17:56
Has thanked: 0 time
Been thanked: 0 time

Re: X-Sim einstellen für 2DOF mit Arduino und Sabertoo

Postby menix » Fri 23. Mar 2018, 07:04

Bist du schon weitergekommen?
menix
 
Posts: 36
Joined: Tue 20. Mar 2012, 19:44
Has thanked: 1 time
Been thanked: 0 time


Return to German language

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron