Winkelsensor statt Poti?

Deutsche Sprache - beachtet den Google Übersetzer oben rechts

Winkelsensor statt Poti?

Postby thechoozen » Tue 4. Sep 2018, 20:02

Hi zusammen,

im moment planen wir einen neuen Simulator aufzubauen, einen ersten erfolgreichen Versuch mit einem 2DOF Sim hatten wir schon vor ein paar Jahren umgesetzt.
Nun wollen wir ein neues Gerät aufbauen und versuchen im Moment ob wir anstatt eines Potis auch einen Winkelsensor einsetzen können um die Motorposition auszulesen. Das ganze hängt an einem Arduino mit Monster Motorshield.

Bei dem Winkelsensor handelt es sich um diese hier (link darf ich als neuer user leider keine posten - Conrad Bestell-Nr: 276149 - 62)

Jetzt stellt sich uns die Problematik das bei Ansteuerung über die X-Pid Variante der Motor nicht stoppt wenn er soll, sondern einfach durchläuft. Wenn man sich die Eigenschaftenseite aufruft sieht man auch das der Sensor passende Werte ausspuckt, diese allerdings ziemlich schnell durchlaufen (als Beispiel Bereich ist 0 - 1024, dann springt er beim ausgelesen Wert gerne mal von 0 auf 104, dann auf 211,395 usw.)

Nun stellt sich uns natürlich die Frage ob das schonmal jemand probiert hat, ob wir einfach etwas falsch machen oder ob das ganze mit dem Sensor überhaupt möglich ist.

Angeschlossen ist der Sensor im Grunde genommen genauso wie ein normales Poti.

Ich hoffe mal das da jemand Rat weiß! und bedanke mich daher einfach schonmal vorab!!!
thechoozen
 
Posts: 1
Joined: Tue 4. Sep 2018, 19:44
Has thanked: 0 time
Been thanked: 0 time

Re: Winkelsensor statt Poti?

Postby sirnoname » Wed 5. Sep 2018, 17:22

Hi,

das müsst ihr beim bewegen mit einem Oszi vermessen. Bei Sprüngen müsst ihr in der Software einen Median Filter beim Einlesen einbauen.
Generell ist ein solches System aber verzögert, d.h. Echtzeitsteuerung geht nur mit agilem Poti.
If a answer is correct or did help you for a solution, please use the solve button.
User avatar
sirnoname
Site Admin
 
Posts: 1732
Images: 45
Joined: Thu 1. Sep 2011, 22:02
Location: Munich, Germany
Has thanked: 35 times
Been thanked: 121 times

Re: Winkelsensor statt Poti?

Postby asticher » Fri 30. Nov 2018, 01:21

Ich habe den selben Sensor, aber nur Sprünge von max. +/- 2.
D.h. da stimmt was nicht.
Ich hatte solche Sprünge durch Vibration und Schläge, falsche Verdrahtung (wirklich alles geerdet?) und durch Bürstenfeuer bei starken DC Motoren (alles geschirmt).
"No Brain, No Pain"

2DOF 360° Full Motion Simulator with HTC Vive, Intel i7; 16GB; Gigabyte Board; Nvidia GTX970Ci; Samsung SSD; Thrustmaster Warthog with FFB; Saitek Pro Pedals, Lilliputs & TM MFDs, Body Shaker + 5.1,
User avatar
asticher
 
Posts: 78
Images: 19
Joined: Wed 5. Sep 2012, 20:18
Location: Germany near Munich
Has thanked: 3 times
Been thanked: 1 time


Return to German language

Who is online

Users browsing this forum: No registered users and 1 guest